Vip 7.2 listViewControl

Discussions related to Visual Prolog
Matthias Greving
Posts: 18
Joined: 21 Mar 2002 0:01

Vip 7.2 listViewControl

Unread post by Matthias Greving » 3 Feb 2009 14:57

Hallo,
an other Vip7.2 issue: if I use a listViewControl in any form or dialog, run the application in debug mode, open the form with the listViewControl in it, close the form, close the application, the application hangs and I can't stop it. A stop form the IDE (shift+F5) does not work, I have to kill vip.exe from the taskmanager to get rid of the application.
Any ideas?
mfg
Matthias

Alexander Doronin
Posts: 7
Joined: 8 Dec 2006 12:59

Unread post by Alexander Doronin » 4 Feb 2009 13:07

Hello Matthias,

Unfortunately we cannot reproduce the problem (we have tried for both ListViewDemo example and some new project wich uses a form).
Maybe there is something special in your project?
Also, which platform are you using?

Kind regards, Alexander Doronin

Matthias Greving
Posts: 18
Joined: 21 Mar 2002 0:01

Unread post by Matthias Greving » 4 Feb 2009 13:36

Hello Alexander,

I can reproduce it on my PC in every application where I use the listViewControl, I even tried an empty application an put it into the about dialog.
Rolanad did try this on his machine and he can't reproduce it.
It looks like a problem with my PC, but in Vip 7.103 I don't have this issue.
I will test this on some other PCs too, maybe I can narrow it down.

I am running Windows XP Service Pack 2.

mfg
Matthias

Matthias Greving
Posts: 18
Joined: 21 Mar 2002 0:01

Unread post by Matthias Greving » 4 Feb 2009 17:59

Hello Alexander,

Roland did a lot of testing and found a way he could reproduce it too.
When, in debug mode, the run stack window, the fact window and the disassembly window are opend we are now both able to see the issue. If I close all these windows, it works fine on my PC too.

I have added the debug file, maybe it helps.

mfg
Matthias
Attachments
debug-vip7201-1.txt
(15.98 KiB) Downloaded 630 times

Alexander Doronin
Posts: 7
Joined: 8 Dec 2006 12:59

Unread post by Alexander Doronin » 5 Feb 2009 11:05

Hello Matthias,

Thank you very much for your assistance.
We have reproduced the problem and will investigate it.

Kind regards, Alexander Doronin

User avatar
Jan de Lint
VIP Member
Posts: 239
Joined: 6 Mar 2000 0:01

Unread post by Jan de Lint » 6 Feb 2009 13:17

Nice detective work! My setup also suffered from this.
At least I know now for the time being what to do: close some windows in stead of pushing them to the side.
]an

Post Reply