vp webbrowser active X

Discussions related to Visual Prolog
drspro2
VIP Member
Posts: 78
Joined: 28 Apr 2006 12:03

vp webbrowser active X

Unread post by drspro2 » 30 Jun 2015 8:18

hi Forum,

I distribute the built in webbrowser control to windows computers in the software package.

On most systems it works good.

Though on 1 windows-machine ( windows server ) where they use the virtual machine through a remote desktop session, the webbrowser, ( built in an exe program ) program generates a windows error (not an error in the vip program ) after
which the windows OS closes the program.


This happens only 2 times out of 10 times, the other 8 times the program behaves without windows errors.

Maybe someone has an idea how to solve it or to what the cause may be.



Thankyou

User avatar
Tonton Luc
VIP Member
Posts: 500
Joined: 16 Oct 2001 23:01

Unread post by Tonton Luc » 29 Jul 2015 8:05

Hi,

:idea: maybee add this in your code :

Code: Select all

browser:set_Silent(true()),

drspro2
VIP Member
Posts: 78
Joined: 28 Apr 2006 12:03

Unread post by drspro2 » 12 Aug 2015 8:02

hi TonTon , thankyou for the answer,


it seems that windows server checks Exe file through DEP systeem, i think it checks foor loops, and i tried to remove everything that could seen as a loop in the events calling, so i hope it works better now,

User avatar
Thomas Linder Puls
VIP Member
Posts: 1622
Joined: 28 Feb 2000 0:01

Unread post by Thomas Linder Puls » 12 Aug 2015 9:27

Most of the webBrowserControl is a part of the Microsoft Internet Explorer. So the essential part of the control is already installed on the computer.

I am afraid that we have also experienced severe problems with it when running in a Citrix environment (which is very similar to remote desktop setups). Our problems have to do with huge memory usage, which leads to a breakdown of the program itself. We have not been able to track down the problem, so I cannot for sure say if it is related to the "remote" part.
Regards Thomas Linder Puls
PDC

Post Reply